首页 - 入门 - K线 - 新股 - 短线 - 波段 - 买卖点 - 看盘 - 抄底 - 成交量 - 均线 - 分时图 - 名词 - 视频 - 理财 - 创业 - 书籍 - 软件 - 大师 - 佣金 - 手机炒股 - 专题
查看行情
股票代码:
当前位置: > 股票学院 > 公式源码 > 正文

通达信公式:四星级主图-凯恩斯的公式

2011年05月05日   www.chaoguba.com   来源:炒股吧   文字大小:【】【】【

通达信公式:四星级主图-凯恩斯的公式

源码大智慧2可用,请老师改写通达信的,造福广大幻友,“线上阴线买,线下阳线卖 ”谢谢!
源码如下:

A1:=DATE <= 13181231;
DRAWTEXTREL(4,5,'流通A股:'+NUMTOSTRN(FINANCE2(7),0)+'万'+'市净率:'+NUMTOSTRN((DYNAINFO(7)/FINANCE2(34)),2)+'昨:'+NUMTOSTRN(DYNAINFO(3),2)+'开:'+NUMTOSTRN(DYNAINFO(4),2)+'高:'+NUMTOSTRN(DYNAINFO(5),2)+'低:'+NUMTOSTRN(DYNAINFO(6),2)+'收:'+NUMTOSTRN(DYNAINFO(7),2)+'涨幅:'+NUMTOSTRN((DYNAINFO(14)*100),2)+'%'+'振幅:'+NUMTOSTRN((DYNAINFO(13)*100),2)+'%'+'换手率:'+NUMTOSTRN((DYNAINFO(37)*100),2)+'%'),linethick1,colorwhite;
DRAWTEXTREL(22,40,'凯恩斯双线'),linethick5,colorred;
DRAWTEXTREL(180,50,'黄点工作线'),linethick1,coloryellow;
DRAWTEXTREL(260,50,'多空停损点'),linethick1,colormagenta;
DRAWTEXTREL(340,50,'线上工作|线下休息'),linethick1,colorwhite;
DRAWTEXTREL(470,50,'最低点靠近工作线低吸'),linethick1,coloryellow;
DRAWTEXTREL(210,100,STKLABEL+' '+STKNAME),linethick5,ColorFFFF80;
DRAWTEXTREL(6,150,'空心:阳线|实体:阴线'),linethick2,colorwhite;
DRAWTEXTREL(10,200,'线上阴线买|买错也要买'),linethick1,colorred;
DRAWTEXTREL(10,240,'线下阳线卖|卖错也要卖'),linethick1,colorgreen;
七天线:MA(C,7),colorgray;
工作线:(EMA(C,14)) * A1,POINTDOT,linethick4,coloryellow;
生命线:(MA(C,25)) * A1,linethick2,colormagenta;
不惑线:(MA(C,40)) * A1,colorcyan;
姊妹线:(EMA(C,56)) * A1,CIRCLEDOT,colorwhite;
长线启动点:(MA(C,99)) * A1,linethick1,Color0099FF;
{卖线:EMA(SLOPE(C,21)*21+C,42),colorred,LINETHICK2;}
A2:="cpzb@cp";
STICKLINE((A2 >= 8),H,L,0.8,1),colorgreen;
STICKLINE(((A2 >= 8) AND (C > O)),O,C,8,1),colorgreen;
STICKLINE(((A2 >= 8) AND (C < O)),C,O,8,0),colorgreen;
STICKLINE(((A2 > 0) AND (A2 <= 2)),H,L,0.8,1),colorred;
STICKLINE((((A2 > 0) AND (A2 <= 2)) AND (C > O)),O,C,8,1),colorred;
STICKLINE((((A2 > 0) AND (A2 <= 2)) AND (C < O)),C,O,8,0),colorred;
STICKLINE(((C >= 工作线) AND (C >= O)),H,L,0.5,1),colorred;
STICKLINE(((C >= 工作线) AND (C >= O)),O,C,8,1),colorred;
STICKLINE(((C >= 工作线) AND (C <= O)),H,L,0.5,0),colorred;
STICKLINE(((C >= 工作线) AND (C <= O)),O,C,8,0),colorred;
STICKLINE(((C < 工作线) AND (C >= O)),H,L,0.5,1),colorgreen;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,8,1),colorgreen;
STICKLINE(((C < 工作线) AND (C <= O)),H,L,0.5,0),colorgreen;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,8,0),colorgreen;
DRAWTEXT((A2 = 1),L,' ̄'),linethick2,ALIGN1,Color208FFF;
DRAWTEXT((A2 = 1),L,'B'),linethick5,ALIGN1,coloryellow;
DRAWTEXT((A2 = 9),H,' ̄'),linethick2,ALIGN1,colorcyan;
DRAWTEXT((A2 = 9),H+0.38,'S'),linethick5,colorcyan;
STICKLINE((A2 = 9),C,O,0,0),colorwhite;
STICKLINE((A2 = 9),C,O,8,0),colorwhite;
STICKLINE((A2 = 9),C,O,7,0),ColorDDDDDD;
STICKLINE((A2 = 9),C,O,6,0),ColorCCCCCC;
STICKLINE((A2 = 9),C,O,5,0),colorwhite;
STICKLINE((A2 = 9),C,O,4,0),ColorEEEEEE;
STICKLINE((A2 = 9),C,O,3,0),ColorDDDDDD;
STICKLINE((A2 = 9),C,O,2,0),ColorCCCCCC;
STICKLINE((A2 = 9),C,O,1,0),colorwhite;
STICKLINE((A2 = 1),C,O,0,0),ColorFFBBFF;
STICKLINE((A2 = 1),C,O,8,0),colormagenta;
STICKLINE((A2 = 1),C,O,7,0),ColorFF22FF;
STICKLINE((A2 = 1),C,O,6,0),ColorFF44FF;
STICKLINE((A2 = 1),C,O,5,0),ColorFF66FF;
STICKLINE((A2 = 1),C,O,4,0),ColorFF88FF;
STICKLINE((A2 = 1),C,O,3,0),ColorFF99FF;
STICKLINE((A2 = 1),C,O,2,0),ColorFFAAFF;
STICKLINE((A2 = 1),C,O,1,0),ColorFFBBFF;

A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
DRAWTEXT((CROSS(A4,A3)),L,'△'),linethick2,ALIGN1,coloryellow;
DRAWTEXT(A7,H,'○'),linethick3,colorgreen;
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
DRAWTEXT((A22 = 0.6),L,'◇'),linethick4,ALIGN1,coloryellow;
DRAWTEXT((A20 = 1),L,'◇'),linethick4,ALIGN1,colorwhite;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.005),3),linethick2,ALIGN1,colormagenta;
STICKLINE(((C >= 工作线) AND (C >= O)),H,L,0.5,1),colorred;
STICKLINE(((C >= 工作线) AND (C >= O)),O,C,8,1),colorred;
STICKLINE(((C >= 工作线) AND (C <= O)),H,L,0.5,0),colorred;
STICKLINE(((C >= 工作线) AND (C <= O)),O,C,8,0),colorred;
STICKLINE(((C < 工作线) AND (C >= O)),H,L,0.5,1),colorgreen;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,8,1),colorgreen;
STICKLINE(((C < 工作线) AND (C <= O)),H,L,0.5,0),colorgreen;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,8,0),colorgreen;
 

(责任编辑:admin)
郑重声明:炒股吧网发布此信息出于传递更多信息之目的,不表明证实其描述或赞同其观点。本站不保证该信息(包括但不限于文字、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。
关于炒股吧 - 法律申明 - 网站律师 - 合作伙伴 - 广告服务 - 诚聘英才 - 征稿启事 - 联系方式 - 意见反馈 - 友情连接 - 网站地图
Copyright©2007-2016 炒股吧 chaoguba.com All Rights Reserved 版权所有 复制必究

特别声明:本站所载文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负。