首页 - 入门 - K线 - 新股 - 短线 - 波段 - 买卖点 - 看盘 - 抄底 - 成交量 - 均线 - 分时图 - 名词 - 视频 - 理财 - 创业 - 书籍 - 软件 - 大师 - 佣金 - 手机炒股 - 专题
查看行情
股票代码:
当前位置: > 股票学院 > 公式源码 > 正文

通达信版副图本公式:obv.macd

2011年06月22日   www.chaoguba.com   来源:炒股吧   文字大小:【】【】【

通达信版副图本公式:obv.macd

{通达信版副图本公式:obv.macd}
OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0))/25000,0),1);
OBVE:=EMA(OBV,3);
DIFF : EMA(OBVE,12) - EMA(OBVE,26),LINETHICK2;
BBDIFF:=DIFF-REF(DIFF,1);
DEA : EMA(DIFF,9),LINETHICK2;
BBDEA:=DEA-REF(DEA,1);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,3,1),COLORFFCC33;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,1),COLOR0099FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,3,1),COLORYELLOW;
IF(BBDEA>0,DEA,DRAWNULL),COLOR9966CC,LINETHICK2;
IF(BBDEA<0,DEA,DRAWNULL),COLOR00FF33,LINETHICK2;
IF(BBDIFF>0,DIFF,DRAWNULL),COLORRED,LINETHICK2;
IF(BBDIFF<0,DIFF,DRAWNULL),COLORCYAN,LINETHICK2;
--------------------------------------------
{STICKLINE(C>=O,C,O,3,0),COLORGREEN;
STICKLINE(C>=O,H,C,3,1),COLORRED;
STICKLINE(C>=O,H,C,3,1),COLORRED;
STICKLINE(C>=O,O,L,3,1),COLORGREEN;
STICKLINE(C<O,C,O,3,1),COLORGREEN;
STICKLINE(C<O,C,O,3,1),COLORGREEN;
STICKLINE(C<O,H,O,3,1),COLORGREEN;
STICKLINE(C<O,C,L,3,1),COLORGREEN;}

VAR3:=MA(C,8)*1.01;
VAR4:=MA(O,13)*1.01;
VAR5:=(MA(HIGH,5)+MA(LOW,5)+MA(CLOSE,5)+MA(OPEN,5)+HIGH+LOW+CLOSE+OPEN)/8;
VAR6:=IF(VAR4>VAR5,VAR4,VAR5);
VAR7:=IF(VAR4<VAR5,VAR4,VAR5);
VAR8:=3/100;
STICKLINE(VAR3>VAR4,VAR3,VAR4,4,1),COLORYELLOW;
STICKLINE(VAR3<=VAR4,VAR3,VAR4,4,1),COLORLIBLUE;
STICKLINE(VAR4>VAR5,VAR4,VAR5,1,0),COLORGREEN;
STICKLINE(VAR4=VAR5,VAR4,VAR5,1,1),COLORRED;
抢1:MA(VAR7,5)*(1-VAR8),COLORGREEN;
防1:MA(VAR6,5)*(1+VAR8),COLORWHITE;
抢2:EMA(VAR6,3)*(1-VAR8),COLORRED;
防2:EMA(VAR7,3)*(1+VAR8),COLORYELLOW;
 

(责任编辑:admin)
郑重声明:炒股吧网发布此信息出于传递更多信息之目的,不表明证实其描述或赞同其观点。本站不保证该信息(包括但不限于文字、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。
关于炒股吧 - 法律申明 - 网站律师 - 合作伙伴 - 广告服务 - 诚聘英才 - 征稿启事 - 联系方式 - 意见反馈 - 友情连接 - 网站地图
Copyright©2007-2016 炒股吧 chaoguba.com All Rights Reserved 版权所有 复制必究

特别声明:本站所载文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负。