首页 - 入门 - K线 - 新股 - 短线 - 波段 - 买卖点 - 看盘 - 抄底 - 成交量 - 均线 - 分时图 - 名词 - 视频 - 理财 - 创业 - 书籍 - 软件 - 大师 - 佣金 - 手机炒股 - 专题
查看行情
股票代码:
当前位置: > 股票学院 > 公式源码 > 正文

通达信指标:成大组合(主\副)

2011年06月22日   www.chaoguba.com   来源:炒股吧   文字大小:【】【】【

通达信指标:成大组合(主\副)

主图(有未来)

流通盘:FINANCE( 7)/10000, NODRAW;
A1A:=EMA(CLOSE, 9);
A1B:=((A1A - EMA(CLOSE, 5)) < 0);
A1C:=((A1A - EMA(CLOSE, 5)) > 0);
A1D:=BARSLAST(A1B);
A1E:=BARSLAST(A1C);
A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);
A20:=SUM(A1F,0);
A21:=IF((A1D > 0),(0 - 2),0);
A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,A1E),0);
A23:=A22 / A1E;
A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);
多方A25 - REF(A25, 1)) + A25)COLOR0000FF,LINETHICK2;
K2:=BACKSET(多方<REF(多方,1),2);
IF(K2,多方,DRAWNULL),COLOR00A600,LINETHICK2;
空方:MA(多方, 15)COLORFF49FF;
K1:=BACKSET(空方<REF(空方,1),2);
IF(K1,空方,DRAWNULL),COLOR00A600,LINETHICK2;
IF(多方>REF(多方,1),多方,DRAWNULL),COLORFFFFCC,LINETHICK4,POINTDOT;
IF(空方>REF(空方,1),空方,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;
STICKLINE((多方 > 空方),空方,多方, 0, 0)COLOR00FFFF;
STICKLINE((空方 > 多方),多方,空方, 0, 0)COLORFF0000;
DRAWTEXT(CROSS(空方,多方),多方 * 1.01,'↓卖')COLOR00FF00;
DRAWTEXT(CROSS(多方,空方),空方 * 0.99,'↑买')COLOR0000FF;
DRAWICON(((REF(A21, 1) = (0 - 2)) AND (A21 = 0)),LOW, 5);
DRAWICON(((REF(A1E, 1) > 0) AND (A1E = 0)),HIGH, 6);

副图(有未来)

百万指标改编:=STICKLINE(C>0,20,20,50,0),COLORCCFF99;
VAR1:=MA(L,1);
VAR2:=MA(H,2);
VAR3:=MA(C,2);
VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;
VAR5:=SMA(VAR4,3,1);
【阳】:SMA(VAR5,3,1),LINETHICK2,COLOR0000FF;
K2:=BACKSET(【阳】<REF(【阳】,1),2);
IF(K2,【阳】,DRAWNULL),COLOR00A600,LINETHICK2;
IF(【阳】>REF(【阳】,1),【阳】,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;
Y1:=SMA(【阳】,3,1);
VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;
【阴】:SMA(VAR6,3,1),LINETHICK2,COLOR00FFFF;
Y2:=SMA(【阴】,3,1);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;
VARC:=MA(C,3)*100/MA(C,10)-100;
VARD:=C*100/MA(C,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VARE<-10,-10,VARE);
VAR10:=IF(VARC>10,10,VARC);
VAR11:=IF(VAR10<-10,-10,VAR10);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR14:=INDEXC;
VAR15:=REF(VAR14,1);
VAR16:=100*(VAR14-VAR15)/VAR14;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*C+VAR1+O+H)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(INDEXC,1);
VAR26:=MA(C,26);
VAR27:=VAR26+2*STD(VAR3,26);
VAR28:=VAR26-2*STD(VAR3,26);
VAR29:=VAR26+2*STD(REF(VAR3,1),26);
VAR2A:=VAR26-2*STD(REF(VAR3,1),26);
D1:=EMA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,2.5,0),COLOR00AAFF;
STICKLINE(D1>=REF(D1,1),D1,D2,1.5,0),COLOR99AAFF;
{STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR99DD00;}
【强弱】:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,COLORFFFFCC;
DRAWTEXT(ISLASTBAR=1 AND CROSS(【强弱】,Y2),80,'短期吃货!'),COLORFFFFCC;
DRAWTEXT(ISLASTBAR=1 AND CROSS(Y1,【强弱】),80,'短期出货!'),COLOR00FF00;
DRAWTEXT(ISLASTBAR=1 AND VAR17>VAR18,60,'个股强于大盘!'),COLORFF66FF;
DRAWTEXT(ISLASTBAR=1 AND VAR12>VARF,50,'大盘处在下降通道'),COLORCCFF99;
DRAWTEXT(ISLASTBAR=1 AND VAR18>=VAR17,60,'个股弱于大盘!'),COLORFFFF00;
DRAWTEXT(ISLASTBAR=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待涨!'),COLOR6699FF;
DRAWTEXT(ISLASTBAR=1 AND VAR1A<VAR1E AND NOT(CROSS(【强弱】,20)),40,'下调减持!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND VAR1D<=VAR1E,40,'盘整阶段!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1F)/VAR1F>0.035,40,'出现井喷行情!'),COLORFF00FF;
 

(责任编辑:admin)
郑重声明:炒股吧网发布此信息出于传递更多信息之目的,不表明证实其描述或赞同其观点。本站不保证该信息(包括但不限于文字、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。
关于炒股吧 - 法律申明 - 网站律师 - 合作伙伴 - 广告服务 - 诚聘英才 - 征稿启事 - 联系方式 - 意见反馈 - 友情连接 - 网站地图
Copyright©2007-2016 炒股吧 chaoguba.com All Rights Reserved 版权所有 复制必究

特别声明:本站所载文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负。